With the release of macOS Catalina 10.15, support for 32bit applications has been removed from the operating system. DataLocker has released device updates to transition to 64bit applications on currently supported products.  To get the latest software for your device please visit our device update page: datalocker.com/device-updates  If your device is manufactured by another vendor you may need to reach out to them. Here is the list of devices with updates to work on macOS Catalina 10.15:


macOS 10.15 Compatible, with minimum version

  • DataLocker Sentry 3 FIPS - 4.8.40
  • Sentry One Standard / Managed - 6.2.0
  • DataLocker SafeStick Managed - 4.8.41
  • DataLocker Sentry EMS - 6.2.0
  • IronKey  D300SM - 6.2.0
  • IronKey  S1000 - 6.2.2
  • DataLocker H300 / H350 - 6.2.2
  • Origin SC100 - 4.8.43
  • Kingston DT4000G2 - 4.8.40
  • Kingston DTVP30DM - 4.8.41


Devices with no planned updates for macOS 10.15 Compatibility 

  • DataLocker H100 - End of Life
  • DataLocker H200 - Limited Support (Windows only)
  • IronKey  S100 - Limited Support (Windows only)
  • IronKey  S200 / D200 - Limited Support (Windows only)
  • IronKey  S250 / D250 - Limited Support (Windows only)
  • DataLocker Sentry FIPS - Limited Support (Windows only)
  • Blockmaster SafeStick - Limited Support (Windows only)
  • IronKey W500 / W700 / W700-SC - Limited Support (Windows only)


Scheduled for a potential future release 

  • DataLocker Sentry 3.0 


32-bit app Pop-Up message macOS


Error Message that is shown on 10.15 Catalina: 


This message will be shown for all devices launched on 10.15 Catalina that haven't been updated to a compatible version. DataLocker recommends updating your device if available to at least the minimum version shown above. Or to purchase a new device if the current device is not in the 10.15 compatible list. 


 


Error Message that is shown on 10.13 High Sierra, and 10.14 Mojave


This message will be shown for all devices launched on macOS 10.13 or 10.14 that haven't been updated to a Catalina compatible version. DataLocker recommends updating your device if available to at least the minimum version shown above to remove the message. If the device is not on the compatible list, then DataLocker recommends staying on macOS 10.14 until a compatible device can be purchased. All devices can still be used on 10.13 and 10.14 by dismissing the message shown.




Datalocker will continue to provide limited support for devices on compatible operating systems, but customers should be aware of the limitations set forth by the OS. Please feel free to contact us if you have any questions or concerns. If your device is Kingston or Ironkey branded they can be contacted at ironkeysupport@kingston.com. Support for Origin devices can be found HERE.


Ironkey is a registered trademark of Kingston Technologies, used under permission of Kingston Technologies. All rights reserved