The FIPS validated encryption module we utilize is only validated for the MS Windows operating environment. At this time only MS Windows is supported.